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About this Practice Workbook...
 This workbook is designed for use in Live instructor-led training and for OnDemand self study. OnDemand videos 

for this course are available on the LEARNserver and through CONNECT Advisor.

 This PDF file includes bookmarks providing an overview of the document. Click on a bookmark to quickly jump to 
any section in the file.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are 
specified first and the metric values second with the metric values enclosed in square brackets. 
For example: 12.0’ [3.4m].

 This course workbook uses the Training and Examples WorkSpace and the Training-Imperial or
Training-Metric WorkSet delivered with the software.

 The terms “Left-click”, “Click”, “Select” and “Data” are used interchangeably to represent pressing the left mouse 
button. The terms “Right-click” and “Reset” are also used interchangeably to represent pressing the right mouse 
button. If your mouse buttons are assigned differently, such as for left-handed use, you will need to adjust 
accordingly.

Have a Question? Need Help?
If you have questions while taking this course, search in CONNECT Advisor for related courses and topics. You can also 
submit questions to the Civil Design Forum on Bentley Communities where peers and Bentley subject matter experts are 
available to help.

Course Level: Fundamental

http://learn.bentley.com
http://learn.bentley.com


Copyright © 2021 Bentley Systems, Incorporated 2DO NOT DISTRIBUTE - Printing for student use is permitted

Templates Overview

Templates are made up of components which in turn are defined by points. One or more components combine to create a template. 
Components can be closed shapes such as an asphalt layer, or they can be open shapes such as cut and fill slopes. Examples of 
components include curb and gutter sections, sidewalks, asphalt layers, aggregate layers, median barriers, or the side slopes to be used 
when in cut and fill areas. 

Templates represent cross sectional geometry. A 3D model is created 
by extruding the template along a 3D geometric path. As the template 
is extruded the template points connect longitudinally to create 3D 
surfaces and meshes.

Templates can be used along a road or rail centerline and profile grade 
line using Corridor tools to model a roadway but they can also be 
applied along any 3D geometry using the Apply Linear Template tool. 
For example, a curb template can be applied around a traffic island. 

Templates are stored in a Template Library File, which has the file 
extension .itl.
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Exercise 1: Review and Edit a Template

Description
Learn to review and edit existing templates.

Skills Taught
 Open a template library

 Review template library structure and contents.

 Review and change a Pavement Section width and slope

 Review and change template parametric constraints
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Open a Template Library

In this section, we will open a template library and become familiar with the create template dialog box.

1. Start the software.

2. Set the WorkSpace and WorkSet

The workspace and workset define standards that are used by the software. The WorkSpace and WorkSet used for this training are 
installed during the software installation.

a. Select Training and Examples from the WorkSpace menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet menu.

3. Open an existing file.

a. Select Browse.

b. Browse to C:\Bentley Training\Using and Editing Templates or the folder where you unzipped the dataset files. 

c. Select the file Corridor-LondonRd.dgn [Metric-Corridor-LondonRd.dgn].

Note: If you get a message stating “Incompatible Civil Data”, this is because the training files are “aligned” to OpenSite Designer. 
Clicking Yes will align the file to the software you are using (OpenRoads or OpenRail Designer). This will have zero impact for training. 
Note that in production, upgrading the file will make the file read-only in OpenSite Designer. Full information is available at Bentley 
Communities - Product Realignment.

Also, note that OpenSite Designer does not have the ability to create Corridors. To use templates in OpenSite Designer you can apply 
them to civil geometry using the Apply Linear Template tool.

4. Review the default template library.

a. Select the OpenRoads Modeling workflow and select the Corridors tab. 

b. Select Corridor > Create > Template > Create Template

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-realignment-incompatible-civil-data
https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-realignment-incompatible-civil-data
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 The Create Template dialog automatically loads the default template library named Civil Templates Imperial.itl [Civil Templates 
Metric.itl]. 

 The configuration variable CIVIL_ROADWAY_TEMPLATE_LIBRARY sets which template library to load for each workspace/
workset.

 The templates and components are organized in the template library using a folder structure much like files are stored on your 
computer. The template folder tree appears on the left side of the dialog.
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 To navigate the folder structure, double-click the folders you want to open or close. The organization of the folder structure is user-
definable. The folder structure also supports common Windows functions, such as drag and drop, cut and paste, etc. Most 
commonly-used commands can be accessed by right-clicking on the folder and template names. 

 Double-clicking a template name sets it as the active template. The Active Template is signified by a red box around the template 
icon. The Active Template is also displayed in the center of the dialog box.
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Explore the Widths and Slopes of a Pavement Section

In this section, we will review the widths and slopes of a pavement section in an existing template.

1. Open and review the project template library.

a. In the Create Template dialog, select File > Open.

2. Browse to and select the project template library in the class data folder: Project Templates - Imperial.itl [Project Templates - Metric.itl].

b. Maximize the dialog. Notice, the current active template is named 2 Lanes listed under Templates > Asphalt Pavt w/Asphalt Shoulders 
>Undivided

3. Change the Active Template to 2 Lanes under the Concrete Pavt w/Concrete Shoulders folder.

a. In the Templates folder, Double-click Concrete Pavt w/Concrete Shoulders to expand the folder.

b. Double click Undivided to expand the folder and review the templates.

c. Double-click on the 2 Lanes template to make it active and editable.
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The template is now displayed. This template is made up of concrete pavement and aggregate base components for the pavement and 
shoulders. The side slopes are made up of end condition components which are used to tie down to an existing terrain model.
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Templates utilize constraints to define the relationship between template points such as the distance or slope between two points. Each 
point can have up to two constraints which is considered a fully constrained point. A fully constrained points position is fixed relative to its 
parent point(s). A point with one or zero constraints is free to move in one or more directions.

In the image below, the CL point is unconstrained (green) and the EOP point is fully constrained (red). The EOP point is located 12 feet 
[3.6 m] from the CL (parent) and at a slope of -2% from the CL (parent). In this example, the parent is the same for both constraints but 
that is not a requirement. 
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The number of constraints a point has is easily identifiable in the interface by the color of the plus sign that represents the point.

 + Red = Fully constrained point with two constraints

 + Yellow = Partially constrained point with one constraint

 + Green = Unconstrained point with zero constraint

The sign of constraint values is also important.

 The distance is positive if the parent has a lower X or Y value than the child.

 The distance is negative if the parent has a higher X or Y value than the child. 

 The sign of the component slope is based on the mathematical slope. 
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4. Review the EOP_R template point properties.

a. Using the wheel mouse button Zoom in so the EOP_R point is easily visible. You can also use the zoom 
buttons at the bottom of the template display window.

b. Double-click on the EOP_R point. 

The Point Properties dialog appears. At the bottom of the dialog are the constraints that define how the EOP_R point is geometrically 
constrained to the CL point.

The values in the Label fields are know an Parametric Labels or Parametric Constraints. These labels allow the same values to easily be 
defined across multiple points. In addition, these values can be changed as the template is being extruded resulting in variable 
thicknesses, slopes, offset distances, etc.
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Change the Widths and Slopes of a Pavement Section

In this section, we will change the width and slope of the Edge of Pavement (EOP_R) using two methods. The first is to 
directly edit the point. The second method we will edit the Parametric Constraint so all points update at once.

1. Change the point using the direct method.

a. If the Point Properties dialog is closed, double click on the EOP_R point.

b. Change the Horizontal constraint value (representing pavement width) to 14 feet [4 meters]. 

c. Click Apply.

The EOP_R point is moved to be 14 feet [4 meters] from the CL point. The points below EOP_R also adjusted because they are 
constrained to be at a 0 horizontal offset from the EOP_R point.

d. Use the zoom tools at the bottom of the template window to adjust the display if necessary.

e. Type -2.5% for the Slope constraint value. 

f. Click Apply.

The points below EOP_R also adjusted because they are constrained to be at a 0 horizontal offset and fixed vertical offset from the 
EOP_R point.

g. Close the Point Properties dialog.

2. Change another point using the direct method.

a. Double click on the EOP1_R point.

b. Change the Vertical constraint value (representing pavement depth) to -0.75 [-0.22].

c. Click Apply.

d. Close the Point Properties dialog.

e. Zoom out to view the full pavement width.
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The pavement depth updated but only for this single point. We could edit the 
other points at the bottom of the pavement layer but that would be time 
consuming and there is a more efficient method using Parametric 
Constraints. This vertical constraint uses the Label named Pavt 1 Depth. All 
of the points at the bottom of the concrete use this same label.The label is 
defined in the Point Properties window.

3. Undo the previous change to the pavement depth.

a. Select the undo icon at the bottom of the Create Template window (not the MicroStation/CAD 
tools Undo) to undo changing the pavement depth.

4. Change the concrete pavement depth by adjusting the Pavt 1 Depth Parametric Constraint.

a. Click on the Active Template tab on the bottom left side of the Create Template dialog.

The Active Template view replaces the tree view of the template library with a list of the elements 
and values in the active template.

b. Expand the Parametric Constraints list.

The Parametric Constraints group lists the predefined constraint value “Labels”. These values can 
be set here as a constant for all templates in this template library. 

Parametric Constraints can also be changed at runtime as the template is dropped along a corridor. 
Every corridor has the ability to set any of the templates values station-by-station using the 
Corridor’s Parametric Constraints functionality (visit the learn.bentley.com for additional training on 
using templates to model a corridor).
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c. Double-click on the Pavt 1 Depth parametric constraint. Notice the default value.

The Edit Default Parametric Value dialog opens and the point(s) constrained by the value are highlighted. There should be 5 points 
highlighted.

d. Change the Pavt 1 Depth default value to -0.5 [-0.15]. 

e. Click OK and observe the changed depth across the entire template.



Copyright © 2021 Bentley Systems, Incorporated 15DO NOT DISTRIBUTE - Printing for student use is permitted

Exercise 2: Assemble a New Template from Existing Components

Description
Create a new template by assembling existing components already in the template library.

Skills Taught
 Set up Dynamic Settings

 Assemble template from existing pavement, shoulder, sidewalk, and end condition components

 Use the Template Library Organizer to copy templates from the standards template library to the project template library

 Add a fill ditch end condition
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Set up Template Options

In this section, we will set up the template options to be able to efficiently assemble components.

1. Open the Dynamic Settings by clicking the icon at the bottom of the template window or selecting Tools > Dynamic Settings.

The Dynamic Settings dialog has many inputs and controls you will use when creating and editing templates.

The current cursor position is shown at the top left corner.

2. Define the Step Options

The step options setup a snap grid in the templates window making it easier to drag and drop components and points accurately. 
Typically, a Step X value of 1.0 and Step Y value of 0.1 provides a good starting point. These values can be adjusted at anytime.

a. Set the Step Options X value to 1.0. 

b. Set the Step Options Y value to 0.1.

3. Clear the Apply Affixes checkbox if it is enabled. 

When set, new components are given designated prefixes and/or suffixes. We do not want that yet but will use this later in the exercise.
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Create and Assemble a New Template

In this section, you will create a new template by dragging and dropping existing components onto the new template to 
define concrete pavement and aggregate base layers for one lane of concrete pavement and a shoulder which will 
function as a bike lane.

1. Click on the Library tab on the left side of the Create Template dialog.

The Library view replaces the active template view.

2. Right-click the Templates > Concrete Pavt w/ Concrete Shoulders > Undivided folder, click New > Template.

3. Type 1 Lane - RT.

The new template is made active and editable in the template window. If it is not, double click on 1 Lane - RT.

4. Add Concrete Pavement layer to the Template

a. Expand the Components > Pavement - New > Concrete Pavt folder.

b. Single click on the 1 Lane template.

Important: Do not right-click or double-click; we want the 1 Lane - RT template to remain Active.

The Preview window in the lower left shows the pavement template and its attachment point (blue box). If a different attachment point 
is desired, click on the new point in the Preview window.
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c. Click and drag the 1 Lane template into the template window.

d. Drag the template to the 0,0 point (the origin). Use the Dynamic Settings dialog to see precisely when you are located at (0,0).

Position can be verified by holding the cursor over the point. If you “missed” you can 

 Move the point to the origin 

 Move the template origin to the point via the Change Template Origin tool which can be reached by right-clicking in the Edit 
Template window.
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5. Adjust the window limits as necessary to see the component. (fit view.)

6. Add Aggregate Base layer to the template.

a. In the Components > Pavement - New > Concrete Pavt, Click the 1 Lane Agg Base template.

b. Drag the upper left corner of the 1 Lane Agg Base template onto the bottom left corner template point named CL1 on the concrete 
pavement component created previously. Release the mouse when the points are coincident and the point highlights. 

Note: When the points are coincident, the top points of the aggregate component get merged into the concrete pavement component 
points as shown.
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If the points are not merged, you will need to fix them:

 Undo (Ctrl-Z) and then repeat the drag steps, taking care to place the points together.

 You can increase the Step settings in the Tools so that the points “snap” together at a greater distance.

 You can use the Check Point Connectivity tool (right-click in the Edit Template window). It identifies points that lie within a tolerance 
and allows you to delete the duplicates (merge).

7. Add the Shoulder components to the template.

a. Expand the Components > Shoulders > Concrete w/Agg Base folder.

b. Click on and then drag the Full Depth template to the EOP point

8. Select File > Save to save the template library.
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Copy Curb Templates into Project Template Library

Sometimes you will need to copy templates from one template library to another. A common use of this is to copy templates from your 
corporate standards template library (which is probably read only) to your project template library where you can edit the templates as 
necessary.

In this section, we will use the Template Library Organizer to copy existing curb templates from the agency template library into the 
project template library so we can then include the curbs on our template.

1. Copy curb and gutter components from the Agency Templates - Imperial.itl [Agency Templates - Metric.itl] into the Project Templates - 
Imperial.itl [Project Templates - Metric.itl].

a. In the Create Template dialog, select Tools > Template Library Organizer.

This dialog allows dragging and dropping of templates and folders between the active template library and another template source. 
The active template library (our standards library that loaded automatically when we restarted the software) is displayed on the left.

b. Click the Browse button.

c. Browse to the folder where the course files are located and select Agency Templates - Imperial.itl [Agency Templates - Metric.itl]

d. Select Open to open the template library.

The template library you opened is shown on the right side of the window. The active template library is shown on the left side of the 
window.

e. Expand the active template library on the left to view the Components folder.

f. Expand the template library on the right to view the Components > Curbs > Curb and Gutter folder on the right.
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g. Drag and drop the Curb and Gutter folder from the right onto the Components folder on the left.

You have now copied an entire folder and all of its contents from one template library to another.
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Copy Ditch Templates into Project Template Library

1. Copy Ditch 1 end condition template from Agency Templates - Imperial.itl [Agency Templates - Metric.itl] into the Project Templates - 
Imperial.itl [Project Templates - Metric.itl].

a. Expand both template libraries to view the End Conditions > Ditch folders.

The Ditch folder on the left is currently empty.

b. Drag the End Conditions > Ditch > Ditch 1 template into the End Conditions > Ditch folder to copy a single template from one template 
library to another. 

c. Click OK.

d. Click Yes when prompted if you want to save the template library.

The templates have been copied from the standards template library: Agency Templates - Imperial.itl [Agency Templates - Metric.itl] 
to our project template library: Project Templates - Imperial.itl [Project Templates - Metric.itl] but now we need to save the project 
template library in order for our changes to take affect.
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2. Review the Curb and Gutter folder and Ditch folder in the template library.

a. Browse to the Components > Curb and Gutter folder and verify that the curb and gutter templates are there.

b. Browse to the Components > End Conditions > Ditch folder and verify the Ditch 1 template is there.
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Add Curb and Gutter and Sidewalk to the Template

In this section, you will add one of the curb and gutter templates copied from the standards template library to the 1 Lane - RT template.

1. Add Curb and Gutter to the 1 Lane - RT template.

a. Browse to the Templates > Concrete Pavt w/Concrete Shoulder > Undivided folder.

b. Double click 1 Lane - RT to make it the active template.

c. Drag the Curb and Gutter Type 1 that resides in the Components > Curb and Gutter folder to the EOS point of the active 1 Lane - RT 
template.

2. Adjust the constraints on the Base_Ext point.

a. Double click on the Base_Ext point to open the Point Properties dialog.

b. Adjust all constraints as shown below and Set Constraint 1 Value = 1.0 [0.30].

c. Click Apply and then close the Point Properties dialog.

The Base_Ext point should now be located 1 foot [0.30 m] to the right of the back of the curb as shown in the image above.
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3. Add sidewalk behind the curb.

a. Expand the Sidewalk folder.

b. Drag and drop the Sidewalk w/Buffers template to the back of the curb template point CURB_BACK_TOP.
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Add End Condition to the Template

End conditions are open components that seek and target existing and proposed terrains and corridor features. 

In this section, you will add an end condition to seek intersection with the existing ground at four different slopes 
depending on the depth of cut or fill.

1. Expand the Components > End Conditions > Cut and Fill folder.

2. Drag and drop the Cut and Fill Slope Table 1 template onto the outside of the sidewalk EC_HINGE point.
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3. Test the End Conditions.

a. Click on the Test button to open the Test End Conditions dialog.

b. Click the Draw button.

c. Drag the cursor up and down. Observe which end condition component finds the Active Terrain Model surface (the horizontal line 
represents the simulated terrain model as you move your cursor).

d. Verify that the solution sequence is correct. Slopes will solve in order from flattest to steepest.

e. Close the Test End Conditions window.
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Create a Two-sided Copy of Template

The template we created only includes the right side. The left side can be defined manually using the same technique 
or we can build it automatically using our drag and drop technique into a new template.

In this section, you will drag the right side template into a new template to create both the right and left sides with proper 
point naming using the affixes defined previously.

1. Create a new Template named 2 Lane Urban.

a. If not already open, open the Dynamic Settings dialog.

b. If not already set, set the Step X value to 1.0.

c. In the Dynamic Settings dialog, enable Apply Affixes.

 When template points are created and the Apply Affixes check box is enabled, 
prefixes (defined at Tools > Options) are automatically added to all point and 
component names. In our workspace all points will contain an _L and _R suffix 
depending on which side of the centerline they are located.
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d. Right-click the Templates folder, click New > Template.

e. Name it 2 Lane Urban. The new template is made active and editable in the template window. If is not, double click on 2 Lane Urban.

f. Single click on the 1 Lane - RT template and drag it into the template window; while dragging (holding the left-mouse), right-click; When 
the pop up menu appears release the left mouse button and select Mirror.

The Mirror option creates a two-sided template from a single sided template. The Reflect option changes its side(s).
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g. Drag the two pavements together at the origin (0,0).

2. Zoom into the point names near the edge of pavement.

Notice that the point names all end with _L or _R.
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3. Merge common pavement components into a single pavement component.

At the centerline where the two mirrored templates come together there are two components that define the pavement layer. Sometimes 
it is desirable to merge these into a single component.

a. Zoom to see the CL where the surface components come together.

b. Right-click on the shared boundary between the left and right top pavement layer, click Merge Components.

The components now become one.
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c. Repeat the Merge process for the aggregate components.

4. As a final cleanup, we should drop the “_R” prefixes from the concrete pavement and aggregate components.

Component names get the affixes just like point names. Normally, we want the components to be labeled _L or _R to help identify where 
they are located. However, now that we have merged the pavement layers into single components across the left and right side they 
would be more accurately named without the affixes.

a. Double click on boundary of the TC_Concrete Pavt_R component (concrete pavement). The Component Selection dialog appears

b. Select TC_Concrete Pavt_R and then Component Properties dialog will appear.

c. Remove the _R prefix from the name.

d. Click Apply and close the dialog.
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5. An alternative to selecting and editing each component individually is to edit them through the Active 
Template list.

a. Click on the Active Template tab on the left side of the Create Template dialog

b. Expand the Components list. 

Notice the components (have a gray shape icon) are prefixed with _L or _R, depending on which side 
of the centerline they’re on.

c. Locate the TC_Aggregate Typ A_R component.

d. Remove the _R from the name.

e. When finished, click the Library tab to return to the main template library view.

6. Click File > Save to save the template library.
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Exercise 3: Modify the Template to Meet Project Needs

Description
In this section, we will modify the template and replace the end conditions to meet project specifications which include a fill slope with cut 
solution.

Skills Taught
 Copy template

 Delete existing slope solutions

 Replace end condition with fill ditch slope solutions
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Add Ditch Template to Cut & Fill Template

Using existing components is an easy way to build the basic template but sometimes additional adjustments are required for specific 
project requirements.

In this section, we will learn how to create a new template that combines a ditch template with the cut and fill end condition template. We will 
not concern ourselves in this class with how the ditch components are constructed. If you are interested in that please consider attending the 
Templates - Defining End Conditions class.

1. Make a copy of the Cut and Fill Slope Table 1 template.

a. In the Components > End Conditions > Cut and Fill folder, right-click the Cut and Fill Slope Table 1 template and click Copy.

b. Right-click the Cut and Fill folder, click Paste. (The Cut and Fill Slope Table 1 template will be renamed to Cut and Fill Slope Table 11).

2. Rename the template.

a. Right-click the new Cut and Fill Slope Table 11 template and click Rename.

b. Type Cut and Fill Slope Table 1 w/Ditch.

c. Double-click it to make it active.

3. Add the Ditch 1 template to the Cut and Fill Slope Table 1 end condition template (Be sure to turn off Apply Affixes otherwise an _R affix 
will be applied to the Ditch 1 template).

a. Single click on the Ditch 1 template inside the Ditch folder and drag it onto the EC_HINGE Point. Note: You will need to right-click and 
disable the Mirror option during the drag.
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The completed template should look like the image below.

4. Test the End Conditions (It is a best practice to always test End Conditions when you edit them).

a. Click Test.

b. Click OK when the Warning appears telling you there are conflicts. It turns out that two (or more) components share the same Priority 
Value and the software does not know what the designer’s priorities are. We will fix this.
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c. In the Test End Conditions dialog, click Check Priorities. The End Condition Priorities dialog shows that there is a conflict at the 
EC_HINGE. Select EC_HINGE and click Edit.

d. Change the Priority values to match the image below.

e. Click OK.

f. The End Condition Priorities dialog now shows no conflicts. Close it.

g. Test the End Conditions. Verify that the Cut and Fill solutions solve in proper sequence.

h. Close the Test dialog.

5. Save the template library.
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Replace End Conditions on the 2 Lane Urban Template

In this section, we will make a copy of the 2 Lane Urban template and replace the existing end conditions with the newly 
created Cut and Fill Slope Table 1 w/Ditch end condition.

1. Copy the template.

a. Right-click the 2 Lane Urban template that resides in the Templates folder and click Copy.

If your 2 Lane Urban template is incomplete or otherwise unusable, you can use the 2 Lanes template instead.

b. Right-click the Templates folder and click Paste.

c. Right-click the new 2 Lane Urban1 template and click Rename.

d. Type 2 Lane Urban w/ Ditch.

e. Double-click 2 Lane Urban w/ Ditch to make it active and editable.
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2. Delete the existing end conditions.

a. Right-click in a clear area of the edit view in the Create Template dialog and select Delete Components.

b. Hold down the left mouse button and drag the cursor over the all the End Condition components. Release the mouse button when you 
are through.

The lower left corner of the Create Template dialog prompts you to drag the cursor over any components you want to delete.
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3. Add Cut and Fill Slope Table 1 w/Ditch template to the left and right side.

a. Enable the Apply Affixes check box in the Dynamic Settings dialog.

b. Click and Drag the Cut and Fill Slope Table 1 w/Ditch template onto the right outermost point, EC_HINGE_R.

Make sure Mirror is enabled. Its status is always displayed in the lower right corner of the Create Template dialog. 

If Mirror is not enabled, enable it by right-clicking while dragging the new template, click Mirror.

c. Release the template when it merges with the EC_HINGE_R point. The point should turn bold and white when being merged into the 
original point placed.

4. Test the template to make sure it behaves as expected.

5. Save the template library.

6. Close the Create Template dialog.

7. If using OpenSite Designer, this concludes the course. OpenRoads Designer and OpenRail Designer users continue to the next exercise.



Copyright © 2021 Bentley Systems, Incorporated 42DO NOT DISTRIBUTE - Printing for student use is permitted

Exercise 4: Create Corridor and Assign Template Drop

Description
In this exercise, you will create a roadway corridor using the template created in previous exercise. You will also learn how to view the corridor 
in 2D & 3D and view the corridor cross sections.

Skills Taught
 Create a Corridor

 Open the Template Library

 Create a Template Drop

 Review the Corridor in 2D & 3D

 Create Dynamic Cross Sections
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Create a Corridor for London Rd.

In this section, you will create a corridor along London Rd. using the template created in the previous exercise.

1. Click anywhere in View 1 to make it active.

2. From the ribbon menu select Corridors > Create > New Corridor

a. Select the London Rd. centerline geometry

b. Set the Feature Definition to Final in the Create Corridor dialog

Feature Definitions for Corridors, control the accuracy and display settings of the Corridor. In 
this course you are going to use Final but other Feature Definitions are available. See 
Appendix A for more information on Corridor Feature Definition properties.

c. In the Name field key in: LondonRd (The name may already be present from when you 
selected the centerline geometry, if so skip this).

d. Right click to accept the active profile.

e. Left click to accept and create the corridor.

Once the Corridor is created the Create Template Drop tool will appear automatically and 
the heads-up display will be prompting you to select a template. The Create Template Drop 
tool is used to assign a template(s) to the corridor at a defined interval along the roadway 
alignment. 

3. Add a template drop to the corridor
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a. Following the heads up prompts, press ALT and the Down Arrow on your keyboard to browse the templates in the template library. 

b. The Pick Template window will appear.

c. In the Pick Template window, click the + to expand the template library folders.

d. Select Templates and click the + to expand the folder.



Copyright © 2021 Bentley Systems, Incorporated 45DO NOT DISTRIBUTE - Printing for student use is permitted

e. Now Select 2 Lane Urban w/Ditch

f. Click OK and Left click to accept.

g. Following the heads up prompts (after each prompt, Left click to accept values and move to next prompt):

 Start Station: Press ALT to lock to Start

 End Station: 80+22 [6+196]

 Drop Interval: 10 [3]

The template drop has been assigned and the corridor is now created.
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Notice there are now corridor elements drawn in the 2D and 3D views. The Corridor Object is created in the 2D view and the Corridor 
Model is created in the 3D view.
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4. Turn off the display of the 3D model reference in the 2D view.

a. Select the References tool (Home > Primary > Attach Tools > References)

b. Select the Corridor-LondonRd.dgn [Metric-Corridor-LondonRd] Notice the Default-3D name in the model column.

c. Click the Display Reference icon at the bottom of the window to turn off the file.

d. Close the References window.
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Review the Corridor in 2D view

In View 1 notice there is a 2D closed shape that is drawn along the 
corridor, this is the Corridor Object. The Corridor Object has properties 
of the corridor assigned to it that can be adjusted as needed.

1. Review Corridor Properties.

a. Select the Element Selection tool.

b. To access the corridor properties, select the Corridor Object or 
Corridor Handle.

c. Hover your cursor over the corridor object or one of the corridor 
handles for a few seconds. A context sensitive toolbar will 
appear, giving you access to other corridor tools.

d. Select the Corridor Properties icon on the toolbar to review the 
properties of the corridor.

Note that the Use Active Profile is set to True. This means the 
corridor will use the active profile associated to the horizontal 
alignment. If you need to use a different profile other than the 
active profile, set the Use Active Profile to False and select the 
desired profile next to the Profile Name field.
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Notice in View 1, the closed dashed shape drawn along the corridor. This shape represents the Template Drop along the corridor. It has 
the properties of the template drop assigned to it that you can adjust as needed.

2. Review Template Drop Properties.

a. To access the Template Drop Properties, select the Template Drop.

b. Hover your cursor over the boundary for a few seconds. A context sensitive toolbar will appear, giving you access to other template 
tools.

c. Select the Template Properties icon on the toolbar to review the properties of the template drop.

If you need to make changes to the template drop, the adjustments can simply be made in the dialog. 
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Review the 3D Corridor Model

The corridor modeling process builds the 3D Model of the corridor by default. Generally, you will be working in the Default 2D model 
most of the time. In this section you learn how to review the 3D model view.

1. Click anywhere in View 2 Default 3-D to make it active.

2. Select the Fit View 

3. Select the Zoom In tool at the top of the view window to zoom in closer to the 3D Model.

4. Select the View Rotation tool at the top of the view window.

5. Left click and hold the left mouse button to begin view rotation. Slowly move your mouse up and down or side to side to rotate the view.

6. Release the left mouse button and Right click to reset.

7. Use the wheel mouse button to zoom in and zoom out to review the 3D model.
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Dynamic Cross Sections

In this section, you will learn to view cross sections using the Dynamic Cross Sections tool. Cross sections are created 
directly from the 3D Model and can be viewed with the Dynamic Cross Sections tool. The interval of the cross sections 
is based on the template drop interval and any critical sections defined in the corridor feature definition. Dynamic Cross 
Sections are always created perpendicular to the alignment that is being used with the Corridor.

1. Select the Element Selection tool.

2. From the ribbon menu select Corridors > Review > Dynamic Sections > Open Cross Section View tool.

3. In View 1, Locate and select the LondonRd Corridor

4. Open View 7 by selecting the view 7 button from the bottom of the screen. View 7 window will appear.
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5. Click in View 7, a cross section should now appear.

Note that Dynamic Cross Sections are displayed in specially defined cross section model views. Any view can be defined to display the 
dynamic cross sections. 

6. In the upper left portion of the window select the down arrow next to View Properties.

7. Set the Vertical Exaggeration to 5.

8. Navigate through the cross sections by pressing the single right arrow to move to the next cross section.
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9. Experiment with navigating the cross sections forward and backward using the left and right arrows. Also, notice in plan view that a light 
blue line is displayed showing the current location the cross section is being displayed at.
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Place Horizontal Temporary Dimensions 

1. Left-click in the cross section view and hold down your right mouse button and select Place Horizontal Temporary Dimension

Place dimension on the right side of the cross section:

a. Pick the CL point.

b. Pick the EOP_R point.

c. Pick a height anywhere on the cross section.
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A temporary dimension line will be placed showing the width and slope.

Place temporary dimension line on the left side of the cross section:

d. Pick CL point.

e. Pick EOP_L point.

f. Pick a height anywhere on the cross section.

2. Navigate through the cross section.
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3. Remove the dimensions:

a. Select Corridors > Review > Dynamic Sections > Remove All Temporary Dimensions

b. Left-click in the cross section view.
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Skills Assessment

The questions below will test your retention of the skills covered in this course.

1. Once a template is created it cannot be modified/updated?

a. True 

b. False

2. Everyone should edit and make changes in a single template library file.

a. True 

b. False

3. Choose the Incorrect answer -

‘In the delivered/sample environment there are____’

a. Components 

b. End Conditions

c. Pre-made Templates

d. Project Libraries

4. Choose the Correct answer -

‘Constraint labels are useful for____’

a. Renaming several points at once

b. Modifying the constraint value across a template

c. Labeling the points correctly from a list

d. Providing the end user with feedback during template placement
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5. “QuickStarts” are introductory courses

a. True 

b. False
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Skills Assessment - Answers

The answers to the skills assessment questions are highlighted below. 

1. Once a template is created it cannot be modified/updated?

a. True 

b. False - It is quite easy to go back and edit an existing template and reuse it.

2. Everyone should edit and make changes in a single template library file.

a. True 

b. False - The “seed” template library file should be in a protected location and a working copy made for each active project.

3. Choose the Incorrect answer -

‘In the delivered/sample environment there are____’

a. Components 

b. End Conditions

c. Pre-made Templates

d. Project Libraries

4. Choose the Correct answer -

‘Constraint labels are useful for____’

a. Renaming several points at once

b. Modifying the constraint value across a template

c. Labeling the points correctly from a list

d. Providing the end user with feedback during template placement
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5. “QuickStarts” are introductory courses

a. True 

b. False
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Summary

In this course, you have learned the many tools and techniques to create and assign a template to a corridor.

You have learned how to:
 Open a template library

 Review template library structure and contents.

 Review and change a Pavement Section width and slope

 Review and change template parametric constraints

 Set up Dynamic Settings

 Assemble template from existing pavement, shoulder, sidewalk, and end condition components

 Use the Template Library Organizer to copy templates from the standards template library to the project template library

 Add a fill ditch end condition

 Copy template

 Delete existing slope solutions

 Replace end condition with fill ditch slope solutions

 Create a Corridor

 Open the Template Library

 Create a Template Drop

 Review the Corridor in 2D & 3D

 Create Dynamic Cross Sections

 Place Horizontal or Vertical Temporary Dimensions
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